AUS/NZ
PC PS XBOX
Sponsors:
Start your own gaming site:
Login:
? Sign Up!
Powered by GIGABYTE
OP
AU
Joined: 14/1/12
Posts: 210
using Chrome 28.0
Rep:
45%
Member
Alright so I've tried to download and install LoL many times and I just can't seem to so I've turned to the PC forum.

Every time I download LoL I run it and nothing happens. There's no installer that pops us or anything, nothing happens

Please help.
Quote
Downvote
Like
4.7 years ago
yolo.
AU
Joined: 26/2/09
Posts: 4,727
using Chrome 54.0
Rep:
72%
Member
Have you googled it?
Quote
Downvote
Like
4.7 years ago
@JakeOCE
OP
AU
Joined: 14/1/12
Posts: 210
using Chrome 28.0
Rep:
45%
Member
Quote from penguin~ on the 15th of April 2012:
Have you googled it?
Yes, yes I have and there's nothing on my problem.
Quote
Downvote
Like
4.7 years ago
yolo.
AU
Joined: 26/2/09
Posts: 4,727
using Chrome 54.0
Rep:
72%
Member
Quote
Downvote
Like
4.7 years ago
@JakeOCE
OP
AU
Joined: 14/1/12
Posts: 210
using Chrome 28.0
Rep:
45%
Member
Quote from penguin~ on the 15th of April 2012:
Oh my god... If you actually read the OP you would understand my problem but since you're from PC you don't and just resort to being a smart ass.

After i open the league of legends installer, i agreed to the 'term of use", then after it is asked to install Pando Media Booster, which i installed, then later the installer disappeared.

That's that guy's problem.

I can't even open the installer.

LOVE PC FOR LYFE...
Quote
Downvote
Like
4.7 years ago
yolo.
AU
Joined: 13/1/10
Posts: 220
using Chrome 30.0
Rep:
36%
Member
Have you tried turning it off and on?
Quote
Downvote
Like
4.7 years ago
Ain't no party like a Pyongyang party, 'cause a Pyongyang party is ABSOLUTELY MANDATORY
OP
AU
Joined: 14/1/12
Posts: 210
using Chrome 28.0
Rep:
45%
Member
Quote from TheReignOfChaos on the 15th of April 2012:
Have you tried turning it off and on?
Yessir
Quote
Downvote
Like
4.7 years ago
yolo.
AU
Joined: 26/2/09
Posts: 4,727
using Chrome 54.0
Rep:
72%
Member
Quote from Elixr on the 15th of April 2012:
SPOILER: Click to view

Have you tried restarting your PC, updating windows, updating your other drives... I was trying to help and you're just being unreasonable..
Quote
Downvote
Like
4.7 years ago
@JakeOCE
Swiftz removed a post by Elixr.
Swiftz removed a post by jake-2iyM-.
Swiftz removed a post by Elixr.
AU
Joined: 18/4/10
Posts: 2,600
using Chrome 52.0
Rep:
62%
Member
Tried running as admin?
Tried re-downloading the launcher?
Tried disabling anti-virus then re-downloading the installer?
Quote
Downvote
Like
4.7 years ago
Youtube - Twitch.TV - Admin for Hardware and Streaming forum - Xsplit Wizard - Twitter
OP
AU
Joined: 14/1/12
Posts: 210
using Chrome 28.0
Rep:
45%
Member
Quote from Shieldeh on the 15th of April 2012:
Tried running as admin?
Tried re-downloading the launcher?
Tried disabling anti-virus then re-downloading the installer?
Yes...
Quote
Downvote
Like
4.7 years ago
yolo.
AU
Joined: 18/4/10
Posts: 2,600
using Chrome 52.0
Rep:
62%
Member
What are your computers specs and what OS + anti-virus do you have?
Quote
Downvote
Like
4.7 years ago
Youtube - Twitch.TV - Admin for Hardware and Streaming forum - Xsplit Wizard - Twitter